
Personal Address File. Version 1.23

ADDRFILE.EXE is prepared by Fedon Kadifeli. This is a utility which can be used for keeping 
personal address information. For example, you can keep people’s addresses, phone numbers, 

e-mail addresses, etc. It is similar to the old Windows CARDFILE.EXE program and it can read 
(.CRD) files created by that program. You can use this program to keep personal notes too, just as 
you can use NOTEPAD.EXE for this purpose. However, by using this program, you can organize your 
data and access any information you need more easily.

Information is stored normally in CSV format, so you can import files created by ADDRFILE to other 
programs, like Microsoft® Excel. You can save to and read from TXT files also. You can optionally 
encrypt and/or compress your CSV files.

Using ADDRFILE, you can read and update phonebook entries of your mobile phone using Serial, 
USB, Bluetooth, or Infrared (IrDA) connection to your PC. Sony Ericsson, Nokia, Motorola, and 
Siemens mobile phones are known to work with ADDRFILE.

ADDRFILE has an integrated phone dialer similar to, but better than the one in CARDFILE. Another 
useful feature is the ability to execute system commands stored in your data file.

This program was written mainly to overcome some limitations of CARDFILE. For example, in 
CARDFILE the size of a card cannot be larger than 12x40 characters including the index line. In 
ADDRFILE there is no such limitation. The main philosophy behind this program is its simplicity and 
easiness of use.

ADDRFILE runs on 32-bit Microsoft Windows environments (like Windows 95, 98, ME, NT, 2000, or 
XP). It gets an optional parameter indicating the address file to be opened and edited. The window 
displayed when you run the application contains a menu bar at the top, a status bar at the bottom, a 
card index list at the right, and a multiline edit box at the left. The text displayed within the edit box at 
the left is related to the card selected from the index list at the right. The index value of a card is the 
first line of the card data. When you start with an empty address file, the first thing you must do is to 
add a new card and then edit the contents of this card. Then you need to save your address file to disk
.

The relative widths of the address information area and the address index list can be adjusted by 
dragging the area between them with the left mouse button. If you double click on this area, the sizes 
will be adjusted to their defaults. The positions of the address information area and the address index 
list can be changed by using the File Setup... menu option.

Program menu options are given below:

File

New Print...
Open... Print Setup...
Save Clear Recent
Save As... Exit
Setup...

Edit



Undo Paste Random String
Cut Delete
Copy Change Case >>>
Copy ASCII Select All
Paste

Search

Indexes... Current Card...
Whole File... Quick Search Items...

Card

Add... Print
Delete Information...
Duplicate Autodial...
Restore Execute >>>

Phonebook

(Re)Open Port... Read
Close Port Update...
Memory Storage >>> Resequence...
Mobile Information... Sort Names >>>
Select Entries

Help

Help Topics About...
Registration...

There are also pop-up menus that give you context-sensitive menu options. The available options are 
the same as the above-listed ones. To see the pop-up menus, press the right mouse button while 
holding the mouse pointer either on the card index list at the right or on the multiline address 
information edit box at the left.

The toolbar has also some icons for frequently used menu options. To see a short explanation of 
these icons, i.e., the menu options they are related, place the mouse pointer on any of these icons 
and wait for a help hint to pop up.

For solutions to some common problems see Troubleshooting and Frequently Asked Questions

Important:

Please read the Disclaimer before using this software.



Disclaimer

By using this software the user implicitly agrees with the conditions and rules stated in the help topic 

Distribution. If you have not read this topic yet, please read it now. If you do not agree with the 
conditions and rules stated in it, please dispose of all contents of this package now in your 
possession.

The author of this software does not accept any responsibilities for damages resulting from the use of 
ADDRFILE software and makes no warranty or representation, either express or implied, including 
but not limited to, any implied warranty of merchantability or fitness for a particular purpose. 
ADDRFILE software is provided as is, and you, its user, assume all risks by using it.



Distribution

ADDRFILE is copyright © 1998-2009 by Fedon Kadifeli. This help topic contains legal binding 
information about distribution of ADDRFILE. If you do not agree with the conditions and rules stated in 
this text, please remove your copy of ADDRFILE.

In this help topic, the term ADDRFILE identifies release version 1.xx of the Address File program. 
The term SHAREWARE version identifies the complete package containing this program. By 
complete package I mean, the executable file, the associated help file, and the readme file. The term 
SHAREWARE copy identifies an instance of the SHAREWARE version. No component part of 
ADDRFILE may be distributed individually, disassembled, copied, reverse engineered, or altered in 
any form. This includes all elements in the ADDRFILE package, interface items, menus, and dialogs.

Distribution

1. SHAREWARE copies may be freely distributed by individual users for trial and leisure utilization.

2. SHAREWARE copies may be uploaded to Bulletin Board Systems, FTP/Web sites, Usenet 
newsgroups, and any network sites providing its users with access to download it for trial and leisure 
purposes. Bulletin Board Systems should restrict downloading charges for the SHAREWARE version 
to flat rate connection fees.

3. SHAREWARE copies may NOT be distributed in CD-ROM disks, diskettes or any other media, 
without express authorization of the author. Authorization for distribution may be obtained in the form 
of a specific, signed, "Non-exclusive Distribution License Agreement."

4. SHAREWARE copies may NOT be distributed with any software package, or be systematically 
recommended to users of any software system or service, without express authorization of the 
author. Authorization for distribution may be obtained in the form of a specific, signed, "Non-exclusive 
Distribution License Agreement."

Non-exclusive Distribution License Agreement

A Non-exclusive Distribution License Agreement must be signed by an authorized licenser of 
ADDRFILE before:

1. Including ADDRFILE on a software product package,

2. Distributing or explicit recommending ADDRFILE usage to clients and/or users of a software 
package or service,

3. Including ADDRFILE on CD-ROMs, diskettes, or any other media,

4. Performing any other form of distribution of ADDRFILE

There is no standard Non-exclusive Distribution License Agreement form. Specific rules are to be 
defined case by case between licenser and interested parties. Agreements may, at discretion of 
licenser, include customization of program interface and/or execution, partial or total disclosure of 
source code, maintenance and/or upgrade clauses.

Using ADDRFILE

ADDRFILE is shareware. The users need not pay a fee for using ADDRFILE for personal usage. 
However, if you plan to use this program, you should register. Users who want to get a permanent 

licence should pay for it.

Contacting the author of ADDRFILE

The author of ADDRFILE can be contacted for any bug, wish, or suggestion.



Registration... Command

ADDRFILE is a shareware program. You can "tentatively" register ADDRFILE at no charge or buy a 
"permanent" licence. To register your copy of ADDRFILE you need a Web access to the Internet. 

When you register, you no longer get this nasty dialog box during program start up saying that This 

program is not licensed!

In other words: ADDRFILE is freeware for those who cannot afford to pay money for personal usage 

of such a program. However, those who can afford to pay 12 USD or those who want to use this 
program in a commercial environment and get support from me need to get a valid and permanent 
licence.

To register with ADDRFILE (obtaining a permanent licence)

1. From the Help menu choose Registration....

2. Enter your user name in the input box labelled Your name. This will be the user name you want 
to register your copy of ADDRFILE. This name must be at least 5 characters long.

3. Connect to the Internet and start your Web browser.

4. Go to the following address: 
https://secure.element5.com/shareit/checkout.html?productid=159010&language=English
You can also go to http://www.shareit.com/ and enter the program ID number 159010 in 

the search window at the bottom left of the screen. As a third alternative, you can click on the Get 

A Permanent Licence button in ADDRFILE.

5. In the input box labelled License to (the first entry under Personal Information) type your user 
name exactly as entered during step 2 above. Correct spelling, capitalization, and spacing is very 
important. Remember, this name must be at least 5 characters long.

6. If you are buying a personal licence (even if you will be using ADDRFILE in more than one PCs), 

enter 1 in the Qty box. If you want to get a site licence, enter the quantity as follows:

Number of systems: Licences to buy (Qty):

1 1 (cost: 12 USD) 

2-5 2 (cost: 24 USD)

6-25 3 (cost: 36 USD)

26-125 4 (cost: 48 USD)

Unlimited 5 (cost: 60 USD)

7. Fill in the other information and complete your transaction.

8. You will obtain a Permanent Registration User Key. Key in or paste this key to the input box 

labelled Your registration user key in ADDRFILE. You should see a message like this: 

Licensed permanently to Your Name.

Note that the registration user key you purchased is only valid for the user name you buy the licence. 
So, the name you entered in the purchase order must match exactly to the one you enter in the 

Registration tab of ADDRFILE (steps 2 and 5 above).

To register with ADDRFILE (without paying money)

1. From the Help menu choose Registration....

2. Enter your user name in the input box labelled Your name. This will be the user name you want 
to register your copy of ADDRFILE.

3. Click on the Copy Registration Request Information push-button and then to OK to copy this 
information (your user name and your registration request number) to the Clipboard.

4. Connect to Internet and start your Web browser.

5. Go to the following address: http://www.kadifeli.com/cgi-bin/regno.pl.

6. Paste this information to the multiline input box labelled Your registration request information. 



Fill in Your e-mail address, and follow the instructions on this web page.

7. After your registration user key is generated, key in or paste this key to the input box labelled 

Your registration user key in ADDRFILE. You should see a message like this: Licensed to 

Your Name.

Steps 3 through 6 above can be automated by just clicking on the Register Online For Free button 
in ADDRFILE.

Note that the registration user key you generated is only valid for the computer you are using and you 
will need to generate a new registration user key if you re-install Windows on your system.

If you choose to type your registration information, instead of copying and pasting it, note that Your 

Registration User Key and Your Registration Request Number consist of four groups of 
hexadecimal numbers (only the digits 0 through 9 and letters A through F) separated by hyphens.

For more current information about registering, please refer to 
http://addrfile.kadifeli.com/#reg. If you are not on-line and want to purchase a 
permanent licence, please contact the author.



Troubleshooting

Some useful hints are given in this section. See also Frequently Asked Questions topic for more 
hints.

Since an address file is stored in CSV format, you can easily edit a file created by ADDRFILE or 
import it into other programs, like Microsoft® Excel (provided that you save your address file 
uncompressed and unencrypted). That way you can do some operations not supported by 
ADDRFILE. For example:

To merge two address files

Use a DOS command like

C:\ADDRFILE>COPY file1.csv+file2.csv merge.csv

which merges the files FILE1.CSV and FILE2.CSV into a single file called MERGE.CSV. When the 
MERGE.CSV file is opened by ADDRFILE, you will get a warning for any cards having the same 
index.

To split an address file into two files

Use any text editor (like NOTEPAD) to open the address file. The editor must be capable of dealing 

with very long lines. Each card will be displayed as a single line. Use your editor's Cut and Paste 
commands to move some cards (i.e., whole lines) to another CSV file.

To recover a deleted card from a backup file

Each time you save your address file, the previous version of your address file is saved with the same 
name, but with a BAK extension. If you delete a card from your file and then save your file, you may 

open the backup file with a text editor and Copy the line containing the deleted card, and Paste it into 
your address file.

Multiple instances of the Personal Address File program

You may open multiple instances of the Personal Address File program. Be careful not to open the 
same address file multiple times, since this may cause some (un)predictable results.

Encryption

Personal Address File uses a proprietary encryption algorithm. The password you enter in the File 

Setup dialog box is used for both encrypting and decrypting the file. If you forget the password of a 
file, the only way to recover it is by trial and error. This can be automated, i.e., every possible 
character combination may be tried until the correct password is found, but the author of this program 
has no intention to develop such a program and make it public. For this reason, try not to forget the 
file password.

Viruses

Personal Address File does not automatically execute any code in the CSV or TXT file, so it is not 
possible to create and spread viruses with Personal Address File documents.

However, the manual command execution may be a security risk. So you are advised to disable this 

option if you are not planning to use it. This can be done by using the Setup... command from the File
 menu.



Frequently Asked Questions

In this section some answers to frequently asked questions are given. See also Troubleshooting for 
solving some problems.

Which files do I need to back up?

ADDRFILE data files are stored in Comma Separated Values files (files with CSV extension). The 
files with BAK extension are for backup purposes (in case you might want to revert to the previously 
saved version). It is enough to archive only the CSV files. However, just for having two versions (the 
current one and the previously saved one) you can back up also the BAK files. The ADDRFILE.EXE 
executable and the associated help files can always be downloaded from my Web site.

When I open my NOTEPAD TXT files, ADDRFILE drops (loses) the first character in the file. 

Why?

When you open a normal TXT file, ADDRFILE uses the first character in the first line as the Card 

Separator Character (See File Setup... command), so that subsequent lines starting with this 
character are put in different cards. For an example, look at the README.TXT file coming with the 
ADDRFILE.ZIP file; it uses "[" as the Card Separator Character.

How can I modify the index line of a card? I try to modify the first line of the card, but this 

change is not reflected in the Address Index List.

Note that there is no Modify Card command in ADDRFILE; the card you modified (including its index 
line) is updated automatically when you switch to another card. So, if you want to modify the index line 
of a card (and as a result, its position in the Address Index List) just select the card you want to 
modify and change the first line in the Address Information Area; then, to update the Address Index 
List, switch to another card or click at the same card in the Address Index List.

I maximized the window and I can't restore it now. The Restore button flickers and changes to 

a Maximize button, but nothing happens. Why?

Before version 1.22: This is a known problem. It occurs only if you save your file while the window is 

maximized. Click on the Restore button so that the button on the left of X (Close button) becomes a 
square, and then move and resize the window as you wish. Do some modifications in your data, so 

that ADDRFILE will allow you to save your file. Do File | Save to save the new settings. Close 
ADDRFILE and then reopen it. Now try again to maximize and restore. It should work. To avoid this 
problem, do not save your file while the ADDRFILE window is maximized. ADDRFILE will save these 
co-ordinates as its "normal" window size, so that when you later try to restore the window it will still 
occupy the whole screen.

In version 1.22 and above: Window state and the "restored" window co-ordinates will be saved in 
your CSV file, so that this problem will not occur.

The program opens in the middle of the screen. But when I open a CSV file, the program 

window shifts to the right so that the right end of the window, including the window controls 

on the title bar, are off the screen. I can reposition the window without problem, but would 

rather the window didn't shift.

Apart from the default window co-ordinates, ADDRFILE stores the specific window co-ordinates for 
each CSV file in the CSV file itself. However these are not updated unless you make changes in the 
data and you save the CSV file.

To solve this problem do this:

1. Open ADDRFILE and your CSV file;

2. Position the window as you like;

3. Modify some data, so that ADDRFILE will allow you to save your file;

4. Do File | Save to save the co-ordinates in your CSV file;

5. Close ADDRFILE;



6. Re-open ADDRFILE and your CSV file (to do this in one step, create a shortcut as described in 
the README.TXT file);

7. The window position will be the same as the one you changed in step 2.

If you have problems with the above procedure try this:

1. Create a copy of your data file;

2. Open your copy with NOTEPAD;

3. Delete the following string from the first line:
WindowState=…,ClientHeight=…,ClientWidth=…,Top=…,Left=…,

4. Save your copy;

5. Try to open this copy

If this does not solve the problem, or ADDRFILE opens with a very small window, you will have do 
delete the whole [HKEY_CURRENT_USER\Software\FedSoft\AddrFile] tree from your 
Windows Registry.

Is it possible to print a file and have a new page start at the beginning of a card, rather than 

the next page starting part way through the card on the previous page? When I print a file can 

I change the default font?

Presently you cannot do these from within ADDRFILE. However you can do the following:

1. Start ADDRFILE program and open your file.

2. Select File | Setup...

3. Click on the Set To Form Feed to set the Card Separator to Form Feed.

4. Click OK.

5. Select File | Save As...

6. Select "Text File (*.TXT)" from Save as type.

7. Give a name (and a path) in File name.

8. Click Save to save your address file as a text file.

9. Start Microsoft Word or any other word processor.

10. Select File | Open and open the newly created text file.

11. Select the whole file and change the font to whatever you like.

12. Print the file. An empty page may be printed in the beginning of the printout. If you want to avoid 
this, go to the first character of the file (use Ctrl+Home) and press Delete to delete the initial Form 
Feed character.

Is there a way to get rid of the most recently used file names in the File menu when these files 

no longer exist or not wanted to be listed?

Before version 1.21: You have to delete them from the Windows Registry. Close any instances of 
ADDRFILE running. Run REGEDIT and go to the key:

\HKEY_CURRENT_USER\SOFTWARE\FedSoft\AddrFile

Then delete any of the four keys File1, File2, File3, or File4 having the values you do not want. 

Restart ADDRFILE and check the File menu.

The usual Registry editing warnings apply; if you delete something important from the Windows 
Registry by mistake, you may make your Windows unusable!

In version 1.21 and above: From the File menu just select Clear Recent. All file names will be 

removed from the File menu.

What is the size limit of each card? Is there a size limit for the whole file?

There is no limit on the CSV file itself. However, a 32 KByte limit per card is imposed to prevent some 



problems.

Is there a functional difference between a permanent licence and a freely obtained one?

There is no functional difference in the software. However, a freely obtained licence is only for 
personal usage and the registration code you get is valid only for the current PC. If you change your 

PC or your operating system, you will need to register again. Otherwise you will get the This program 

is not licensed! warning. A permanent licence, on the other hand, is tied to your name and not to 
your PC. You can use the same code even if you change PCs or operating systems. You can also get 
a licence for more than one user by applying for a site licence.

When you register your copy of ADDRFILE by getting a free licence, the message displayed on the 

Help | Registration... window is something like this: Licensed to Your Name. When you purchase a 

permanent licence and enter the code to the program, the message changes to this: Licensed 

permanently to Your Name.

I'd like to know if I can use the ADDRFILE from a CD or compact flash disk.

There is no reason why you can't use ADDRFILE from a CD, floppy, or USB (mobile) disk. You can 
store ADDRFILE.EXE, your data file, or both on a removable medium. But, note that if you store your 
data file on a slow or read-only removable medium, you may wish to disable the automatic save 

feature of ADDRFILE. To do this go to File | Setup... and set Auto save every 0 minutes.

It would be nice to be able to print a list of the right side [Index] of the program as well as the 

whole card.

It is true that there is no such facility in ADDRFILE right now. But you can use the following method:

1. Save your data file as an unencrypted and uncompressed CSV file.

2. Open the CSV file in Microsoft® Excel or any other spreadsheet application that can read CSV 
files.

3. Delete the first line of the spreadsheet (it is used by ADDRFILE to keep setup information).

4. Delete all but the first column of the spreadsheet.

5. Format and print the document. 

What is the meaning of this error message?

Cannot save in CRD format! ADDRFILE cannot save files with CRD extension. You can either save 

the file in CSV or TXT format. Use the File | Save As... command.

Current card too long. To prevent some problems a limit of 32 KBytes per card is imposed. 
ADDRFILE will not allow you to have a card with more than 32768 characters. (Note that end of lines 
count as two characters.)

Format error on key # number!

Internal error ...!

Unable to read card count!

Unable to read data for key # number!

Unable to read data length for key # number!

Unable to read key # number! The CRD file you are trying to open has a format error. Please send 
this file to me for further investigation.

Header not recognized! The CRD file you are trying to open has not a recognizable header. 
ADDRFILE can only read Windows CARDFILE files having either the MGC or RRG magic header. 
Please send this file to me for further investigation.

Please, select/verify your Font Script in File | Setup... before using this command! Look at the 

end of File | Setup... help topic.

Port open canceled! You canceled the Open Mobile Phone's Port dialog box.

Problem in saving alternate file. If you give a name for the alternate save file name in the File | 

Setup... dialog box, then a second copy of your data file will be created each time you save your 
address file. However, if the alternate path you specified is not available during save you will get this 
error message. Also, you will get the same error message if both your primary and the alternate file 



name refer to the same location.

Too many command-line parameters! ADDRFILE can accept at most one command-line 
parameter. This is the name of the data file to be opened. If you tried to run ADDRFILE from 
command line, please be sure to give at most one parameter. If you tried to run ADDRFILE from a 

Windows shortcut, check the Target field in the shortcut definition.

Unable to read header! The CRD file you are trying to open is too short. Probably it is not of 
Windows CARDFILE format.

Unknown extension: .ext. ADDRFILE can only open files having extension CSV, CRD, and TXT. It 
will refuse to open a file with another extension. You may rename the file to one of the above 
extensions and try to open it.

Wrong Password! The data file you are trying to open has a password, but you failed to specify the 
correct password. Note that passwords are case sensitive.

I cannot open your web page?

This may be a temporary problem. Please go to your favorite search engine and search for fedon 

kadifeli addrfile. You should be able to find several backup pages. If you wish, you can contact me 
to report the problem.

Can I change the print font to get a better looking output?

ADDRFILE currently uses Courier New 10pt for printing. This is hard coded in the program. I will 
consider to make this more flexible in the future.

My index window is narrow; shows two characters. I must set it to normal default width using 

the keyboard. I am blind using Jaws, speech and Braille.

The index window can only be resized by putting the mouse pointer between the index and the 
information area window and dragging the mouse left or right.

The window sizes are stored in your data file. If you open a new data file (using File | New), the 
windows will start with default values.

The only way to resize the windows, would be to close ADDRFILE and edit your data file (.CSV file) 
with a text editor like NOTEPAD. Look for the "CardWidth=" value on the first line of your data file. 
Decrease the value after the "=" sign (it is in number of pixels).



New File Command

Purpose

The New command is used to clear any address file loaded in memory and start with a new empty 
address file.

To open a new address file

1. From the File menu choose New.

2. If there is already an address file in memory which is not saved, you are prompted to save it.

Tip: After a new address file is created in memory, first you need to add a card and then update it. 
You can continue adding or editing cards. Finally you need to save your address file. Since a new 

address file has no name, you can either use the Save or Save As command. In any case you will be 
prompted to give a name to your new file.

The new file can be saved in either CSV or TXT format. However, CSV is the recommended format, 
since file setup information and encrypted data cannot be saved in TXT format.

Note: Shortcut for this command is Ctrl+N.



Open... File Command

Purpose

The Open command is used to load an address file or Windows "CardFile" from disk to memory.

To open an old address file

1. From the File menu choose Open....

2. In the dialog box displayed give the name of the file to open. You can open CSV files (the 
default), CRD files, or TXT files. CRD files are files created by the old Windows CARDFILE 
program. ADDRFILE can read CRD files, but cannot save data in CRD format. The loaded file 
needs to be saved in CSV or TXT format. CSV is recommended.

Note: Windows CARDFILE (that is, the CRD format) allows you to have two or more cards having the 
same index value. This is not allowed in ADDRFILE. So, if this is case on an input file, ADDRFILE 
appends a period to the end of the second card with same index value encountered in the input file. 
You can then modify the index value of a card directly by editing the first line of the card data.

Other ways to open a file

� If you run ADDRFILE from command line, you can specify the file to opened by giving it as 
parameter. For example:

C:\ADDRFILE>ADDRFILE myfile.csv

or

C:\ADDRFILE>ADDRFILE readme.txt

� Alternatively, you can run ADDRFILE, drag a file from Windows Explorer, and drop it in a running 
window of ADDRFILE to open it.

Opening password protected files

If you try to open an encrypted address file, you will be prompted for the correct password of the file. 
Unless you give the correct password, you will not be able to open the file. Note that passwords are 
case sensitive.

Autosave files

The automatic save feature of ADDRFILE saves your address file with a name having $$$ extension 
at a specified interval to disk to prevent loss of data in case of system or program crash. You can 
recover files saved by the automatic save feature when you try to open the original file. When you 
open a file, if there is a file with the same name, but with $$$ extension, you will be given the option to 
open that file instead. This is called an autosave file. If you want to keep the contents of the autosave 
file, you must save it immediately over the original or a new file.

Note: Shortcut for this command is Ctrl+O.



Save File Command

Purpose

The Save command is used to save the address file in memory to disk.

To save an address file

1. From the File menu choose Save.

2. If you already have given a name to file, the address file information is stored on this file. The old 
version of the file is saved with the same name, but with extension BAK. If you have not already 

given a name to your file, the Save As command is executed automatically.

Note: If you want to determine whether an address file in memory is given a name or not, you can 
look at the window title of the Address File program. A CRD file cannot be saved; use the Save As 
command to save it in CSV format.

When you save an ADDRFILE in TXT format, take care not to specify a Card Separator character 
that appears in the beginning of a line in your data. If this is the case, a space character will be 
inserted in front of the lines starting with the card separator character and a warning message will be 
given.

This command is unavailable if you have not modified the address file. 

Note: Shortcut for this command is Ctrl+S.



Save As... File Command

Purpose

The Save As command is used to save the address file in memory to a new file on disk.

To save an address file with a new name

1. From the File menu choose Save As....

2. You will be asked to give a new name to your address file. If there is an old file with the same 
name, you will get a warning. If you reply with Yes, the old address file will be renamed by giving 
the extension BAK. The current information will be saved on the file you specified.

You can save a file in either CSV or TXT format. However, CSV format is the recommended format, 
since file setup information will not be saved in TXT format.



File Setup... Command

Purpose

The Setup command is used to modify some attributes of the currently open address file.

To make setup modifications on an address file

1. From the File menu choose Setup....

2. A dialog box with three tabs will be opened:

In the File Setup tab there are 10 options described below:

i. You can give a password to your CSV file, so it will be saved in encrypted form.

ii You can compress your CSV file, so that it will take less space on your disk when saved. 

Normally the address file is saved uncompressed. Low (Quick) compression is 
recommended; the other compression levels may be too slow.

iii. You can specify whether text in address information area should be displayed word wrapped 
or not.

iv. You can specify the Card Separator character (default is Form Feed) to be used when you 

save your file in TXT format. See Save... command.

v. If you want to move the address index list from right to left and the address information area 

from left to right, you can select Left in Index list at.

vi. If you want to save a copy of your file with $$$ extension periodically, then you can specify 
the autosave period in minutes. To disable the autosave feature, set the period to 0 minutes.

vii. If you want to disable command execution from ADDRFILE, you can deselect the Enable 

command execution option.

viii. You can specify the number of spaces to be inserted before each line on printouts.

ix. If you want, you can specify a path name for a "mirror" copy of your data file. If Alt. save file 

name is given as a non-null string, then a second copy of your data file will be created each 
time you save your address file. This will be identical to the original file. This feature is 
intended for problems arising outside your usage with ADDRFILE, such as disk crashes or 
unintentional file deletions. So, it is advised to select your alternate save file name in another 
hard drive, preferably on a networked computer or a removable disk.

x. You can change the font used for both the address information area and the address index 

list by using the Change Font... and the Default Font... buttons. Using the Change Font... 
button you can select any font and special font attribute present in your computer. The 

Default Font... button is used to revert to the build-in default font of ADDRFILE. Before using 

the Copy ASCII and the Change Case >>> command, the correct font Script should be 
selected from this dialog box.

The Quick Search Items tab can be accessed also with the Quick Search Items... command 

from the Search menu.

The Autodial tab is used by the Autodial... command from the Card menu.

After you change the setup of the file and try to close it, ADDRFILE will prompt you to save the file. 
File setup in information is saved only in CSV formatted files.

Autosave files

The autosave feature is useful for periodically storing a copy of the address file being edited to a 
temporary file in CSV format. If the file has a password, then the temporary file will be stored in 

encrypted form also. For more information see the Open... command.

Selecting appropriate font script

The commands Copy ASCII and Change Case >>>, use the information in the font Script selected 



in the Change Font... and Default Font... dialog boxes. Currently only the Turkish and Western 
scripts are supported. You can contact the author for support on more scripts.

Please note: After selecting Default Font..., go to the Script drop down list box and (re)select the 

appropriate script. If you just click on the OK button of the Font dialog box without (re)selecting the 

appropriate script, some "default" script will be selected and this will cause a warning like "Please, 

select/verify your Font Script in File | Setup... before using this command!"



Print... File Command

Purpose

The Print command is used to print the whole address file on your default printer.

To print an address file

1. From the File menu choose Print....

2. If you answer Yes to the confirmation message, the whole address file in memory will be printed 
on the default Windows printer.

Tip: You can specify the number of spaces to be inserted before each line on printouts by using the 

Setup... command from the File menu.

Warning: If your address file is long, the output may take many pages.



Print Setup... Command

Purpose

The Print Setup command is used to display the Windows Print Setup dialog box.

To change the setup of your printer

1. From the File menu choose Print Setup....

2. Do any modifications to your printer's setup.

Later, you may use the Print command from the File menu to print the whole address file or the Print 

command from the Card menu to print the currently selected card.



Clear Recent Command

Purpose

The Clear Recent command is used to clear the recently used file names from the bottom of the File 
menu.

To clear the recently used file names

1. From the File menu choose Clear Recent.

2. If there are any of the most recently used file names at the end of the File menu, they will be 
deleted from the menu.

Normally, the most recently used four address file names are listed at the end of the File menu. This 
list is stored in the Windows Registry.



Exit Command

This command terminates the program. If there is an address file in memory which is not saved, then 
you are prompted to save it.



Undo Edit Command

Purpose

The Undo command is used to reverse the last edit action made on the address information.

To undo your last edit action

1. From the Edit menu choose Undo.

This command may not be always available. See also the Restore command in the Card menu.

Note: Shortcut for this command is Ctrl+Z.



Cut Command

Purpose

The Cut command is used to remove any selected text from address information and put it on the 
Clipboard.

To cut text from address information

1. Select the text you want to cut.

2. From the Edit menu choose Cut.

3. The selected text is moved to the Clipboard.

This command is unavailable if you have no selected text. Use the Paste command to paste this text 
to another place.

Note: Shortcut for this command is Ctrl+X.



Copy Command

Purpose

The Copy command is used to place a copy of any selected text from address information to the 
Clipboard.

To copy text from address information

1. Select the text you want to copy.

2. From the Edit menu choose Copy.

3. The selected text is copied to the Clipboard.

This command is unavailable if you have no selected text. Use the Paste command to paste a copy 
of this text to another place.

Note: Shortcut for this command is Ctrl+C.



Copy ASCII Command

Purpose

The Copy ASCII command is used to place a copy of any selected text from address information to 
the Clipboard. Any non-ASCII characters in the text are converted to their nearest ASCII characters. If 

the current font script (which can be selected in the File Setup...) is Turkish, then the Windows 1254 
(i.e., Turkish) character set is assumed. Otherwise Windows 1252 (i.e., Western) character set is 
assumed.

To copy text from address information as ASCII

1. Select the text you want to copy.

2. From the Edit menu choose Copy ASCII.

3. Any selected text is copied to the Clipboard as ASCII characters. For example, a selected text 
such as "Boğaziçi Üniversitesi" is copied as "Bogazici Universitesi" to the 
Clipboard if Turkish script is in effect, otherwise it is copied as "Bodazici Universitesi".

This command is unavailable if you have no selected text. Use the Paste command to paste a copy 
of this text to another place.



Paste Command

Purpose

The Paste command is used to insert a copy of the Clipboard contents at the insertion point.

To paste text to address information

1. Place the insertion point to the place in address information where you want to paste the contents 
of the Clipboard. Or, select the text you want to be replaced.

2. From the Edit menu choose Paste.

3. If there is already a selected text in address information, it is replaced by the contents of the 
Clipboard. Otherwise, the contents of the Clipboard are inserted at the place of the cursor.

This command is unavailable if there is no copied text on the Clipboard.

Note: Shortcut for this command is Ctrl+V.



Paste Random String Command

Purpose

The Paste Random String command is used to insert a 10-character string of random characters at 
the insertion point.

To paste a random string to address information

1. Place the insertion point to the place in address information where you want to paste the random 
string. Or, select the text you want to be replaced.

2. From the Edit menu choose Paste Random String.

3. If there is already a selected text in address information, it is replaced by a 10-character string of 
random characters. Otherwise, the string is inserted at the place of the cursor.

The random string consists of 10 characters randomly selected from the ASCII range between "!" 
(ASCII code 33) and "~" (ASCII code 126). You can use this feature to generate random passwords. 
Use this command several times in sequence to create longer strings. Ignore or delete characters 
that you do not like.

The effects of this command cannot be undone; however you can use the Restore command in the 

Card menu.

Note: Shortcut for this command is Ctrl+R.



Delete Command

Purpose

The Delete command is used to remove any selected text from address information.

To delete text from address information

1. Select the text you want to delete.

2. From the Edit menu choose Delete.

3. Any selected text is deleted from address information area.

This command is unavailable if you have no selected text. Deleted text cannot be recovered, unless 

you immediately use the Undo command or the Restore command from the Card menu.



Change Case >>> Command

Purpose

The Change Case command is used to change the case of the selected text to lowercase or to 
UPPERCASE or to tOGGLE tHE cASE (i.e., convert lower to UPPER and UPPER to lower) or to 
Capitalize the selected text (i.e., convert the first letter of each word to UPPER and the rest to lower). 

If the current font script (which can be selected in the File Setup...) is Turkish, then the Windows 
1254 (i.e., Turkish) character set is assumed. Otherwise Windows 1252 (i.e., Western) character set 
is assumed.

To change the case of a text

1. Select the text you want to change the case.

2. From the Edit menu choose Change Case >>>.

3. From the Change Case sub menu choose lowercase, UPPERCASE, tOGGLE cASE, or 

Capitalize as appropriate.

This command is unavailable if you have no selected text.

The effects of this command cannot be undone; however you can use the Restore command in the 

Card menu.

Note: Shortcut for the lowercase sub command is F10, for the UPPERCASE sub command is 

Shift+F10, for the tOGGLE cASE sub command is Ctrl+F10, and for the Capitalize sub command is 
Shift+Ctrl+F10.



Select All Command

Purpose

The Select All command is used to select all the text in the address information area.

To select all the text in the address information area

1. From the Edit menu choose Select All.

2. All the text in the address information area, including the first line (the index value of the card) will 
be selected.

This command is unavailable if no card is selected.

See also the Select Entries command in the Phonebook menu.

Note: Shortcut for this command is Ctrl+A.



Search Indexes... Command

Purpose

The Search Indexes command is used to search and replace a string in address index list.

To search and replace a string in address index list

1. From the Search menu choose Indexes....

2. In Find what enter the string you want to search for.

3. Select Match case, if you want to search a string matching exactly in case with the string you 
entered.

4. Click Find Next. If a matching index string is found, that card will be opened and the matching 
string will be selected.

The Replace dialog box is left open. You can select Find Next, to find the next occurrence. Search 
starts from the next character position in the current index and proceeds circularly, that is, if end of 
address file is reached it continues from the start of the file.

If you want to replace the matched string with a new one, enter the replacement string in Replace 

with and click Replace. To replace all instances of the text at once, click Replace All. Please note 
that the replace command cannot be undone.

Note: Shortcut for this command is F4.



Search Whole File... Command

Purpose

The Search Whole File command is used to search and replace a string in address file.

To search and replace a string in address file

1. From the Search menu choose Whole File....

2. In Find what enter the string you want to search for.

3. Select Match case, if you want to search a string matching exactly in case with the string you 
entered.

4. Click Find Next. If a matching string is found in the address file, the card that contains that string 
will be opened and the matching string will be selected.

The Replace dialog box is left open. You can select Find Next, to find the next matching string. 
Search starts from the next character position and proceeds circularly, that is, if end of address file is 
reached it continues from the start of the file.

If you want to replace the matched string with a new one, enter the replacement string in Replace 

with and click Replace. To replace all instances of the text at once, click Replace All. Please note 
that the replace command cannot be undone.

Note: Shortcut for this command is F3.



Search Current Card... Command

Purpose

The Search Current Card command is used to search and replace a string in the current card.

To search and replace a string in current card

1. From the Search menu choose Current Card....

2. In Find what enter the string you want to search for.

3. Select Match case, if you want to search a string matching exactly in case with the string you 
entered.

4. Click Find Next. If a matching string is found in the currently selected card it will be selected.

The Replace dialog box is left open. You can select Find Next, to find the next matching string in the 
current card. Search starts from the next character position and proceeds circularly, that is, if end of 
current card is reached it continues from the top of the card.

If you want to replace the matched string with a new one, enter the replacement string in Replace 

with and click Replace. To replace all instances of the text at once, click Replace All. Please note 
that the replace command cannot be undone.

Note: Shortcut for this command is Shift+F3.



Quick Search Items... Command

Purpose

The Quick Search Items command is used to add, modify, or delete quick search strings.

To modify quick search items

1. From the Search menu choose Quick Search Items... The Setup dialog box opens.

2. Use the controls in the Quick Search Items tab to add, modify, or delete quick search strings. 
You can define up to nine quick search strings. These strings will be displayed at the bottom of 

the Search menu in the main window.

3. If you are satisfied with the definitions you made, select the OK button to save the results and 

update the Search menu list. Otherwise, select the Cancel button to cancel your changes.

To search for a specific string you defined, select the appropriate menu item (1 through 9) from the 

Search menu. If that item is preceded with an "f", the search will be done on the whole file (as if the 

Whole File... command was selected from the Search menu); if it is preceded with an "i", the search 
will be done only on the address index list.

In previous versions of ADDRFILE, Quick Search Items were stored in the Windows Registry. 
Starting with version 1.14, they are also stored in the currently open address file, so you may specify 
different Quick Search Items for each CSV address file you have.

Note: Shortcut for this command is F6.



Add... Card Command

Purpose

The Add command is used to add a new card to the address file.

To add a new card to the address file

1. From the Card menu choose Add....

2. In the Add Card dialog box enter the card index, that is, the first line of the address information. 
This cannot be an empty string.

3. A new card will be added to the address file. That card will be opened for editing. Enter any 
additional information starting from the second line in the address information area.

Tip: Leave a blank line after the first line and start typing from the third line. It looks better.

Note: Shortcut for this command is F7.



Delete Card Command

Purpose

The Delete command is used to delete the selected card from the address file.

To delete a card from the address file

1. Before deleting a card, you must open that card. Select the card you want to delete.

2. From the Card menu choose Delete.

3. If you really want to delete the currently selected card, answer Yes to the question.

A deleted card cannot be recovered. See Troubleshooting.

Note: Shortcut for this command is Ctrl+Del.



Duplicate Card Command

Purpose

The Duplicate command is used to duplicate the selected card in the address file.

To duplicate a card in the address file

1. Select the card you want to duplicate.

2. From the Card menu choose Duplicate. Another copy of the selected card is inserted into the 
address file.

The duplicated card has the same index as the card being duplicated, except that (at least) one 
period is appended to the end to make it unique.



Restore Card Command

Purpose

The Restore command is used to restore the address information of a card to the state it was when 
you started editing that card.

To restore a card in the address file

1. From the Card menu choose Restore.

When you start editing a card, the contents of that card are copied to a temporary area and you make 
your address information edits in this area. When you move to another card or choose some menu 
options, the contents of this area overwrite the original contents of the card. Before leaving the 
current card, you may wish to get rid of all the changes you made and revert to the original contents 
of the card. The Restore command can be used to do this. If you wish to undo only the last edit 

operation, then use the Undo command in the Edit menu.

This command is unavailable if the current card has not been modified.



Print Card Command

Purpose

The Print command is used to print the address information of the currently selected card.

To print a card in the address file

1. Select the card you want to print.

2. From the Card menu choose Print. The selected card will be printed on the default Windows 
printer.

You can specify the number of spaces to be inserted before each line on printouts by using the Setup

... command from the File menu.

Note: Shortcut for this command is Ctrl+P.



Card Information... Command

Purpose

The Information command is used to display some basic information about the currently selected 
card.

To get information about the currently selected card

1. Select the card you want to get information.

2. If you want, you may select a portion of the text in the card.

3. From the Card menu choose Information.... Information (such as the length of the card and the 
length of the selected text in the card if any) will be displayed.

The number of lines selected will include both the line where the selection begins and the line where 
the selection ends. For example, if you start the selection from the middle of a line and end it in the 
middle of the next line, the number of selected lines will be displayed as 2.

The number of characters does not include any end of line characters.

Note: Shortcut for this command is Ctrl+I.



Autodial... Command

Purpose

The Autodial command is used to dial a phone number from the currently selected card.

To use this feature you need to have a modem connected to your PC.

To dial a phone number

1. From the Card menu choose Autodial.... The Setup dialog box opens.

2. Use the controls in the Autodial tab to make modifications in your dialing preferences. These are 
explained below:

i. In the International calls group box specify your own country code (for example, this will be 

1 for U.S., 44 for U.K., and 90 for Turkey). Enter also the prefix (the carrier code) which is 
needed to make international calls.

ii. In the Long-distance calls group box specify your own area code (for example, this will be 

718 or 212 for New York, 171 or 181 for London, 212 or 216 for Istanbul). Enter also the 

prefix (the carrier code) which is needed to make long-distance calls.

iii. If you are behind a PBX, in the To access an outside line group box enter the number(s) 

you need to dial in order to access an outside line (for example, I use 9w at work and nothing 

at home). For the meaning of special characters (like w) in a dial string, look at the AT 
command set of your modem.

iv. In the Modem group box specify the number of the PC Port to which your modem is 
connected. For example, if your modem is connected to COM1 or I/O Port A of your PC, 

specify 1. For COM2 or I/O Port B of your PC, specify 2. For USB, Bluetooth, or Infrared 

(IrDA) connections this may be 3, 4 or a larger number (see below). For Dial type select 

Tone or Pulse. If you are not sure what to choose, just test with Tone and if this does not 

work choose Pulse.

All the above options are specific to a computer, so they are saved in your Windows Registry 

when you click OK.

v. In the Characters in phone numbers group box you need to give your preferences about 

how you format phone numbers in your Address File. The characters To be ignored (the 
default is only the space character) are characters that are embedded in phone numbers but 

have no other meaning except to improve readability. The characters Used as separators 
(the default is parentheses) are characters delimiting country codes and area codes (if 
present) from the phone numbers. Examples are given below. The modifications you do in 

this group are saved in your Address File when you click OK.

3. The Original phone number is a string selected from your card containing the phone number to 
be dialed including (possibly) the country and area code. This string is selected as follows: 
Starting from the cursor position a string including the numerals 0 to 9 plus the characters given 

above (Characters in phone numbers) is searched. This string must contain at least three 
digits. If end of card is reached before locating such a string the search starts from the top of the 
card.

4. The Number to be dialed is obtained after applying the rules detailed below. If you want, you can 
edit this number.

5. To dial that number click on the Dial! button. A message will be displayed. Pick up the phone and 

click OK only after dialing is complete.

Phone numbers in your Address File can be saved in various formats:

555 1234 just the phone number
(212) 555 1234 area code, plus phone number
(90) (212) 555 1234 country code, plus area code, plus phone number

ADDRFILE will try to match your country and area code and then remove unneeded parts. For 



example, assume that

My country code: 90
Use dial prefix: 0
My area code: 212
Use dial prefix: 0
Characters to be ignored: <space>
Characters used as separators: ()

In this case:

Phone number in your Address File: Number to be dialed:
(90) (212) 555 1234-222/3 5551234
(90) (111) 555 1234-222/3 0 111 5551234
(11) (212) 555 1234-222/3 0 0 11 212 5551234
(11) (111) 555 1234-222/3 0 0 11 111 5551234
 (212) 555 1234-222/3 5551234
 (111) 555 1234-222/3 0 111 5551234
 555 1234-222/3 5551234

Here, 90 or 11 is the country code and 111 or 212 is the area code in the original phone number; 
555 1234 is the phone number; and 222/3 are some extra numbers we want to be ignored. In this 

example, if you include the dash (minus) character in the Characters to be ignored, then the phone 
number will include the 222 string also.

To find out which port your modem is connected (if the connection is not done through a 

serial port)

1. From Windows Start menu select Programs | Administrative Tools | Computer Management, 

then go to the Device Manager under System Tools and click on Modems or just select 

Modems from Windows Control Panel.

2. There should be an entry for your modem. Right click on it and select Properties.

3. Go to the Modem tab and look at the port name at the top. This should be something like COMx.

4. Enter the number x in the Modem port input box.

Note: Shortcut for this command is F8.



Execute >>> Command

Purpose

The Execute >>> command is used to run an external Windows program from within ADDRFILE.

Note: To use this feature, you need to have the Enable command execution option enabled. By 
default this option is enabled, so you can run commands. But, for security reasons you may wish to 

disable this option. This can be done by using the Setup... command from the File menu.

To execute a command

1. Position the cursor to a string containing a command in your address file or completely select the 
command and its parameters (if any).

2. From the Card menu choose Execute >>>. 

3. From the Execute sub menu select the displayed command and the command will be executed. 
If you have not selected a command and there are spaces or end of lines around the cursor, then 

<Nothing> will be displayed and nothing will be executed.

Some example commands are given below. Execution depends on your Windows configuration and 
the programs installed on your PC. Note that, if you do not select some string, an automatic selection 
not including spaces and end of line characters will be made.

1. http://addrfile.kadifeli.com/

2.
mailto:test@kadifeli.com?Subject=Testing&Body=Your_message&Bcc=bcc@kadifeli.com&Cc=cc@kadifeli.com

3. telnet://telnet.kadifeli.com/

4. gopher://gopher.kadifeli.com/

5. ftp://ftp.kadifeli.com/

6. C:\windows

7. notepad c:\test.txt

8. \\filesrv\share1

The first five commands will try to access some URLs on the Internet. The sixth command will open 
Windows explorer for the given directory (if this directory is present). The seventh command will run 
NOTEPAD.EXE if it is present. If you select the parameter c:\test.txt together with the command 
notepad, then it will be given as parameter to the NOTEPAD command. The eighth command will try 
to browse a directory on another server on your local area network.

Note: Shortcut for this command is F9.



(Re)Open Port... Command

Purpose

The (Re)Open command is used to specify the port number of your PC to which your mobile phone is 
connected.

To change or specify the port number

1. From the Phonebook menu choose (Re)Open Port....

2. In the dialog box give the number of the PC port to which your mobile phone is connected. For 

example, if your mobile phone is connected to COM1 or I/O Port A of your PC, specify 1. For 

COM2 or I/O Port B of your PC, specify 2. For USB, Bluetooth, or Infrared (IrDA) connections this 

may be 3, 4 or a larger number (see below).

3. If this port is valid and not used by another program it will be opened, but no test will be done for 
the type of the device connected to this port.

To find out which port your mobile phone is connected (if the connection is not done through 

a serial port)

1. Connect your mobile phone to your PC according to the instructions given in your mobile phone's 
User Guide. The connection may be done through a USB port or a Bluetooth or Infrared (IrDA) 
link.

2. From Windows Start menu select Programs | Administrative Tools | Computer Management.

3. Go to the Device Manager under System Tools and click on Modems.

4. There should be an entry for your mobile phone. Right click on it and select Properties.

5. Go to the Modem tab and look at the port name at the top. This should be something like COMx.

6. Use the number x in the ADDRFILE Open Mobile Phone's Port prompt.



Close Port Command

Purpose

The Close command is used to close the port your mobile phone is connected.

To close the port

1. From the Phonebook menu choose Close Port.

2. ADDRFILE will close this port, so that you will be able to use your mobile phone from another 
application.



Memory Storage >>> Command

Purpose

The Memory Storage >>> command is used to define the location of the phonebook memory 

storage used by the phonebook commands Read and Update....

To define the phonebook memory storage

1. From the Phonebook menu choose Memory Storage >>>.

2. From the Memory Storage sub menu select SIM Card, Phone, or Other.... If you select Other..., 
you will be prompted to specify the two-letter memory storage code.

3. After that, the Read and Update... Phonebook commands will operate on the selected memory.

Tip: SIM Card is the default and recommended memory location.

ADDRFILE uses "SM" for the SIM Card selection and "ME" for the Phone selection. Some mobile 
phones may use different values or may have additional memory storage locations. In this case, use 

the Other... selection and enter the two-letter code of the memory storage you want to use. Some 
example codes are (these are highly dependent on the model of your mobile phone):

"DC" Dialled numbers,

"MC" Missed calls,

"RC" Received calls.

Please note that some memory storage locations may not be updatable, so the Update... Phonebook
 command may return an error.



Mobile Information... Command

Purpose

The Mobile Information... command is used to retrieve some useful information about the 
connected mobile phone.

To retrieve mobile information

1. From the Phonebook menu choose Mobile Information.... If necessary, you will be asked about 

the port number, exactly as if the (Re)Open Port command has been chosen.

2. ADDRFILE will query the connected mobile phone and will display retrieved information.

If the port opened is not connected to a mobile phone, you may get some error messages and the 
information displayed will not be complete.

Tip: To place a copy of the displayed information to the clipboard press Ctrl+C.



Select Entries Command

Purpose

The Select Entries command is used to select all the lines except the index line in the address 
information area.

To select all phonebook entries in the address information area

1. From the Phonebook menu choose Select Entries.

2. All the text in the address information area, excluding the first two lines (the index value of the 
card and the following empty line) will be selected.

This command is unavailable if no card is selected.



Read Command

Purpose

The Read command is used to read phonebook entries stored on the SIM card or in the mobile 
phone memory into the address information area of the currently open card.

To read phonebook entries in the address information area

1. If necessary, using the Memory Storage >>> command select the memory location of your 
mobile phone you want to read.

2. From the Phonebook menu choose Read. If necessary, you will be asked about the port 

number, exactly as if the (Re)Open Port command has been chosen.

3. All the phonebook entries stored in the selected memory storage of your mobile phone will be 
copied into the address information area of the currently open card. The first two lines (the index 
value of the card and the following empty line) will be preserved; the rest will be overwritten with 
new data.

Note: SIM Card is the default and recommended memory location.

If you mistakenly overwrite data in the address information area use the Restore command in the 

Card menu.

The format of a typical phonebook entry is as follows:

<index>,<number>,<type>,<text>

<index> Location number for the storage of the phone details.

<number> Phone number (in quotations).

<type> 128-255: Type of ISDN/Phone numbering plan.
129: Nationality unknown.
145: International.
161: National.
If a '+' is included in the phone number <number>, then a default of 145 is used; in 
all other cases a default value of 129 is applied.

<text> Name or description of the phone number (in quotations).

This command is unavailable if no card is selected.



Update... Command

Purpose

The Update command is used to update phonebook entries stored on the SIM card or in the mobile 
phone memory from data in the address information area of the currently open card.

To update phonebook entries in the address information area

1. If necessary, using the Memory Storage >>> command select the memory location of your 
mobile phone you want to update.

2. From the Phonebook menu choose Update.... If necessary, you will be asked about the port 

number, exactly as if the (Re)Open Port command has been chosen.

3. All the phonebook entries stored in the selected memory storage of your mobile phone will be 
compared with the ones present in the address information area of the currently open card. All, 
excluding the first two lines (the index value of the card and the following empty line) will be used 
for this purpose. If there is a mismatch, then your mobile phone's phonebook need to be updated 
and a dialog box will inform you about the necessary changes.

4. In the displayed dialog box, click OK to commit the changes into your mobile phonebook. 

Otherwise, select the Cancel button to cancel your changes.

Note: SIM Card is the default and recommended memory location.

To delete all entries from your mobile phone, select an empty card and then use the Update... 
command.

This command is unavailable if no card is selected.

Note: Shortcut for this command is F5.



Resequence... Command

Purpose

The Resequence command is used to resequence the number locations (the numbers before the 
first comma of each line) in the phone entries.

To resequence the number locations in the address information area

1. From the Phonebook menu choose Resequence.

2 Specify the number to be used for the first entry. This is normally 1, but for some phones or 

memories another number (like 101) needs to be given.

3. All the number locations in the address information area, excluding the first two lines (the index 
value of the card and the following empty line) will be resequenced starting from the given 
number. The first line will start with the given number, the second with the given number+1, the 
third with the given number+2, and so on.

This command can be used to "squeeze" the gaps in the phonebook entries and to make them 
continuous and unique.

This command is unavailable if no card is selected.



Sort Names >>> Command

Purpose

The Sort Names >>> command is used to sort lines containing phonebook entries in the address 
information area in ascending name order.

To sort phonebook entries in the address information area

1. If you are going to use the Sort Names >>> | Selected command, select the phonebook entries 
you want to sort. Be sure to select complete lines starting from the beginning of the first line you 
want to select and going the beginning of the line following the last line you want to select.

2. From the Phonebook menu choose Sort Names >>>.

3. From the Sort Names sub menu select All or Selected.

4. Lines in the address information area will be sorted in ascending name order.

Name is the entry described as <text> in the Phonebook Read command.

This command is unavailable if no card is selected.



Personal Address File. Version 1.23

ADDRFILE.EXE is prepared by Fedon Kadifeli. This is a utility which can be used for keeping 
personal address information. For example, you can keep people’s addresses, phone numbers, 

e-mail addresses, etc. It is similar to the old Windows CARDFILE.EXE program and it can read 
(.CRD) files created by that program. You can use this program to keep personal notes too, just as 
you can use NOTEPAD.EXE for this purpose. However, by using this program, you can organize your 
data and access any information you need more easily.

Information is stored normally in CSV format, so you can import files created by ADDRFILE to other 
programs, like Microsoft® Excel. You can save to and read from TXT files also. You can optionally 
encrypt and/or compress your CSV files.

Using ADDRFILE, you can read and update phonebook entries of your mobile phone using Serial, 
USB, Bluetooth, or Infrared (IrDA) connection to your PC. Sony Ericsson, Nokia, Motorola, and 
Siemens mobile phones are known to work with ADDRFILE.

ADDRFILE has an integrated phone dialer similar to, but better than the one in CARDFILE. Another 
useful feature is the ability to execute system commands stored in your data file.

This program was written mainly to overcome some limitations of CARDFILE. For example, in 
CARDFILE the size of a card cannot be larger than 12x40 characters including the index line. In 
ADDRFILE there is no such limitation. The main philosophy behind this program is its simplicity and 
easiness of use.

ADDRFILE runs on 32-bit Microsoft Windows environments (like Windows 95, 98, ME, NT, 2000, or 
XP). It gets an optional parameter indicating the address file to be opened and edited. The window 
displayed when you run the application contains a menu bar at the top, a status bar at the bottom, a 
card index list at the right, and a multiline edit box at the left. The text displayed within the edit box at 
the left is related to the card selected from the index list at the right. The index value of a card is the 
first line of the card data. When you start with an empty address file, the first thing you must do is to 
add a new card and then edit the contents of this card. Then you need to save your address file to disk
.

The relative widths of the address information area and the address index list can be adjusted by 
dragging the area between them with the left mouse button. If you double click on this area, the sizes 
will be adjusted to their defaults. The positions of the address information area and the address index 
list can be changed by using the File Setup... menu option.

Program menu options are given below:

File

New Print...
Open... Print Setup...
Save Clear Recent
Save As... Exit
Setup...

Edit



Undo Paste Random String
Cut Delete
Copy Change Case >>>
Copy ASCII Select All
Paste

Search

Indexes... Current Card...
Whole File... Quick Search Items...

Card

Add... Print
Delete Information...
Duplicate Autodial...
Restore Execute >>>

Phonebook

(Re)Open Port... Read
Close Port Update...
Memory Storage >>> Resequence...
Mobile Information... Sort Names >>>
Select Entries

Help

Help Topics About...
Registration...

There are also pop-up menus that give you context-sensitive menu options. The available options are 
the same as the above-listed ones. To see the pop-up menus, press the right mouse button while 
holding the mouse pointer either on the card index list at the right or on the multiline address 
information edit box at the left.

The toolbar has also some icons for frequently used menu options. To see a short explanation of 
these icons, i.e., the menu options they are related, place the mouse pointer on any of these icons 
and wait for a help hint to pop up.

For solutions to some common problems see Troubleshooting and Frequently Asked Questions

Important:

Please read the Disclaimer before using this software.



Registration... Command

ADDRFILE is a shareware program. You can "tentatively" register ADDRFILE at no charge or buy a 
"permanent" licence. To register your copy of ADDRFILE you need a Web access to the Internet. 

When you register, you no longer get this nasty dialog box during program start up saying that This 

program is not licensed!

In other words: ADDRFILE is freeware for those who cannot afford to pay money for personal usage 

of such a program. However, those who can afford to pay 12 USD or those who want to use this 
program in a commercial environment and get support from me need to get a valid and permanent 
licence.

To register with ADDRFILE (obtaining a permanent licence)

1. From the Help menu choose Registration....

2. Enter your user name in the input box labelled Your name. This will be the user name you want 
to register your copy of ADDRFILE. This name must be at least 5 characters long.

3. Connect to the Internet and start your Web browser.

4. Go to the following address: 
https://secure.element5.com/shareit/checkout.html?productid=159010&language=English
You can also go to http://www.shareit.com/ and enter the program ID number 159010 in 

the search window at the bottom left of the screen. As a third alternative, you can click on the Get 

A Permanent Licence button in ADDRFILE.

5. In the input box labelled License to (the first entry under Personal Information) type your user 
name exactly as entered during step 2 above. Correct spelling, capitalization, and spacing is very 
important. Remember, this name must be at least 5 characters long.

6. If you are buying a personal licence (even if you will be using ADDRFILE in more than one PCs), 

enter 1 in the Qty box. If you want to get a site licence, enter the quantity as follows:

Number of systems: Licences to buy (Qty):

1 1 (cost: 12 USD) 

2-5 2 (cost: 24 USD)

6-25 3 (cost: 36 USD)

26-125 4 (cost: 48 USD)

Unlimited 5 (cost: 60 USD)

7. Fill in the other information and complete your transaction.

8. You will obtain a Permanent Registration User Key. Key in or paste this key to the input box 

labelled Your registration user key in ADDRFILE. You should see a message like this: 

Licensed permanently to Your Name.

Note that the registration user key you purchased is only valid for the user name you buy the licence. 
So, the name you entered in the purchase order must match exactly to the one you enter in the 

Registration tab of ADDRFILE (steps 2 and 5 above).

To register with ADDRFILE (without paying money)

1. From the Help menu choose Registration....

2. Enter your user name in the input box labelled Your name. This will be the user name you want 
to register your copy of ADDRFILE.

3. Click on the Copy Registration Request Information push-button and then to OK to copy this 
information (your user name and your registration request number) to the Clipboard.

4. Connect to Internet and start your Web browser.

5. Go to the following address: http://www.kadifeli.com/cgi-bin/regno.pl.

6. Paste this information to the multiline input box labelled Your registration request information. 



Fill in Your e-mail address, and follow the instructions on this web page.

7. After your registration user key is generated, key in or paste this key to the input box labelled 

Your registration user key in ADDRFILE. You should see a message like this: Licensed to 

Your Name.

Steps 3 through 6 above can be automated by just clicking on the Register Online For Free button 
in ADDRFILE.

Note that the registration user key you generated is only valid for the computer you are using and you 
will need to generate a new registration user key if you re-install Windows on your system.

If you choose to type your registration information, instead of copying and pasting it, note that Your 

Registration User Key and Your Registration Request Number consist of four groups of 
hexadecimal numbers (only the digits 0 through 9 and letters A through F) separated by hyphens.

For more current information about registering, please refer to 
http://addrfile.kadifeli.com/#reg. If you are not on-line and want to purchase a 
permanent licence, please contact the author.



© 1998-2009, Fedon Kadifeli.

Address: Cumhuriyet cad. 22-24, Elmadag, 34367,
Istanbul, Turkey.

Phone: +90-212-314 2818.

Mobile: +90-532-407 8419.

Fax: +90-212-314 2855.

E-mail: support-addrfile-1.23@kadifeli.com

Web: http://addrfile.kadifeli.com/

Registration: http://addrfile.kadifeli.com/#reg

Important: Please read the Disclaimer before using this software.


